Контакты Поиск

[ вход ]
[ последние сообщения ]

  • Страница 1 из 1
  • 1
Форум » SourceMod >> CS:Source >> CSGO » Плагины (бесплатные) » VIP [Player Balance] v1.0.2 (Баланс VIP игроков в конце раунда)
VIP [Player Balance] v1.0.2
_wS_ Дата: Четверг, 07.04.2022, 13:37:19 | Сообщение # 1
VIP [Player Balance] v1.0.2 (модуль для VIP) (csgo, css, css v34)
Доступно только для пользователей [ как устанавливать VIP модули ]

Если в одной из команд на 2+ VIP игрока больше, то их по одному перемещает в противоположную команду в конце раунда. Если хотя бы один VIP игрок был перемещен и в командах получилось неравное кол-во игроков, начинает перемещать обычных. Перемещает тех игроков (и VIP и обычных), которые имеют наименьшее кол-во фрагов.


Сообщение отредактировал _wS_ - Четверг, 22.09.2022, 17:13:41
 
_wS_ Дата: Воскресенье, 10.04.2022, 19:47:07 | Сообщение # 2
По привычке на sm 1.10 писал, оставил его прикреплённым для тех, у кого не css v34. Переделал под 1.6.3, т.к. некоторые еще на нём (css v34). На myarena есть тестирование 1.11 для css v34, но похоже не всё ещё работает + сам sm еще не релизнул 1.11. Пока все модули будут писаться/компилироваться под sourcemod 1.6.3 на старом синте, чтобы не было проблем с css v34, при этом такие модули будут работать и на 1.10+ и тд, на 1.6.3+ в общем. И как в этом случае, дополнительно могут быть прикреплены версии под sm 1.10+.
 
Dangerous707 Дата: Четверг, 14.04.2022, 22:05:27 | Сообщение # 3
Сообщений: 66
Репутация: -1 [ +/- ]
_wS_, я тебя прошу, начни уже под 1.9+ писать. В 34-й 1.6.3/1.7.3 юзают только, вот честно, идиоты и те, кто просто свой первый сервер создал.
1.10 и 1.11 очень-ОЧЕНЬ распространены. MyArena не добавляет свой в ПУ тупо из-за того, что, как я понял, им лень. Всё стабильно, куча серверов на них сидят, всё прекрасно уже не первый год.
А 1.9 нужен потому, что в 92+ CSSDM расширение не портировано, так что на дезматчах люди могут 1.9 юзать из-за безвыходного положения.
Приучай дебилов обновлять SM. Они обновят и не уйдут на другую VIP, не зря ведь 950 рублей потратили. И самому тебе, наверное, не очень приятно между двумя синтаксисами мотаться


Сообщение отредактировал Dangerous707 - Пятница, 15.04.2022, 00:07:20
 
_wS_ Дата: Пятница, 15.04.2022, 15:39:58 | Сообщение # 4
Цитата Dangerous707 ()
_wS_, я тебя прошу, начни уже под 1.9+ писать. В 34-й 1.6.3/1.7.3 юзают только, вот честно, идиоты и те, кто просто свой первый сервер создал. 1.10 и 1.11 очень-ОЧЕНЬ распространены. MyArena не добавляет свой в ПУ тупо из-за того, что, как я понял, им лень. Всё стабильно, куча серверов на них сидят, всё прекрасно уже не первый год.

Я сегодня позаходил на несколько топовых css v34 серверов, которые вверху в мониторинге у myarena.
Появилась аллергия на:

Код
] sm
The command "sm" is blocked!

Но удалось увидеть sm 1.10 и 1.11 на нескольких серверах.
Ок, начну тогда спокойно писать на новом синте, в пекло этот 1.6.3 =)

Цитата Dangerous707 ()
А 1.9 нужен потому, что в 92+ CSSDM расширение не портировано, так что на дезматчах люди могут 1.9 юзать из-за безвыходного положения.

Это такое себе, если честно, оставаться на 1.9 ради чего-то такого, тем более этих dm plugin'ов полно, и я делал где-то есть. Я буду компилить на 1.10, т.к. там enum struct работает, а эта штука очень удобна. Плюс в 1.10 utf8mb4 поддерживается и есть новые нативы и команды.

Спс что подтолкнул =)
 
Dangerous707 Дата: Пятница, 15.04.2022, 19:03:29 | Сообщение # 5
Сообщений: 66
Репутация: -1 [ +/- ]
Цитата _wS_ ()
Появилась аллергия на:

] sm
The command "sm" is blocked!

В той же ProcessCMDS по дефолту это включено, люди просто не смотрят. Да и на топовые сервера смотреть я бы не стал, ибо там одни заводы играют, владельцы ничего нового почти не привносят. Сидят и на старых SM, и аж за ClientMod банят. Тупо донаты с глупых роботяг рубят

Цитата _wS_ ()
Это такое себе, если честно, оставаться на 1.9 ради чего-то такого, тем более этих dm plugin'ов полно, и я делал где-то есть.

Ну, CSSDM востребован из-за простоты и функциональности, он зарекомендовал себя. Реально схожих аналогов, пожалуй, для CS:S нет.
В 34-й он портирован и работает на 1.10+, а вот в OB проблема...

Цитата _wS_ ()
Я буду компилить на 1.10, т.к. там enum struct работает, а эта штука очень удобна. Плюс в 1.10 utf8mb4 поддерживается и есть новые нативы и команды.

Спс что подтолкнул =)

Очень рад gut
 
_wS_ Дата: Воскресенье, 15.05.2022, 08:45:14 | Сообщение # 6
v1.0.1

При перемещении живых игроков, их не убивает.
 
Lexx77 Дата: Среда, 25.05.2022, 10:42:47 | Сообщение # 7
Сообщений: 34
Репутация: 0 [ +/- ]
А по релевантности способностей никак нельзя сделать балансировку + добавить уведомление в текстовом чате тем кого перекидывает за другую команду(а то человек не понимает что произошло и почему он оказался в другой команде).

По поводу релевантности способностей, дело в том когда на сервере работает ночная Вип, то платные Випы могут спокойно всей толпой играть за противоположную команду и из-за этого получается жесткий дисбаланс в победах.
 
Neo95 Дата: Понедельник, 12.09.2022, 00:47:35 | Сообщение # 8
Сообщений: 1
Репутация: 0 [ +/- ]
Ws подскажи модуль вип баланс добавил плагин все работает,транслатион добавил все в випках прописал, но на сервере не видно в випке автобаланс виперов
 
_wS_ Дата: Понедельник, 12.09.2022, 22:17:57 | Сообщение # 9
Цитата Neo95 ()
но на сервере не видно в випке автобаланс виперов

В меню ничего не добавляется, это просто баланс в конце раунда.
 
_wS_ Дата: Четверг, 22.09.2022, 17:41:06 | Сообщение # 10
v1.0.2

Баланс происходит не сразу в конце раунда, а через (mp_round_restart_delay - 0.15) сек, т.е. почти сразу перед началом нового раунда.
mp_round_restart_delay должно быть > 0.
 
Форум » SourceMod >> CS:Source >> CSGO » Плагины (бесплатные) » VIP [Player Balance] v1.0.2 (Баланс VIP игроков в конце раунда)
  • Страница 1 из 1
  • 1
Поиск: